We continue to closely monitor recovery efforts by our third-party vendors following the October 20 AWS outage. Our team has initiated maintenance jobs to ensure all data is synchronized and up to date. These processes will run for some time as data is validated and reconciled, and we’ll provide further updates once maintenance is complete and full recovery is confirmed.
Posted Oct 20, 2025 - 16:49 EDT
Identified
Recovery efforts by our third-party vendors remain in progress, with mitigations underway. We are actively tracking their status to identify the appropriate time to initiate maintenance activities to ensure complete data recovery.
Posted Oct 20, 2025 - 12:44 EDT
Investigating
Following the early outage reported by AWS, several major incidents have now been reported by our vendors, Snowflake and Domo. We are actively investigating the potential impact and will provide an update as soon as more information becomes available.
Posted Oct 20, 2025 - 10:22 EDT
This incident affected: Upstream Services (Service Providers) and SmartSense Reporting.